FRAPS 3.0 not working with games in Windows 7 but DWM mode working

Discussion in 'FRAPS Help Requests' started by DamonMac, Mar 7, 2010.

Thread Status:
Not open for further replies.
  1. I have windows 7 ultimate, Fraps used to run without any problem on my system and displayed FPS, but for some reason it is not working now.

    Cannot take screen shots, neither the Overlay is displayed. Although the DWM Capture works and i can take screen shots of desktop but when i run any game no FPS is displayed and also nothing happens if i press screen shot key.

    Can someone tell me how to fix this.

    additional details:
    Used version 2.8, 3.0 as well
     
  2. ETAdmin

    ETAdmin Administrator Staff Member

    What game are you trying to record?

    Also, have you tried launching fraps before launching the game?
     
  3. Yes i have tried launching the FRAPS before game starts, not to mention several restarts to make sure everything is right.

    Its strange though, here are some wierd things with fraps on my system:

    FRAPS would work with IL2 STURMOVIK 1942 Game
    Displays FPS for Desktop windows manager mode
    DWM capture works perfectly
    FRAPS doesnt work with any other game.
    I have COD MW 2 it doesnt work with that neither these games (PES 2009, MOH airborne, Resident Evil 5 and many other games)


    I dont know why it does work with il2 and not any other game


    And also i attached a debugger and it seems that FRAPS32.dll does hook with each and every process but is unable to display FPS.

    Also tried these things
    reinstall fraps
    tried version 2.8 to 3.0 to the latest avail
    tried to disable Aero effect but nothing.

    Any other information just let me know. ill post it, i hope there is a solution for it
     
  4. Finally i managed to solve the problem. I hope if someone else has this problem this forum post will help them solve it.

    Reason why FRAPS couldnt show the FPS overlay on the games was this:

    Registry Keys which implement Dll Injection in Windows was enabled by a software and these values were set :

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Windows\AppInit_DLLs = "d3dgearload.dll"

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Windows\LoadAppInit_DLLs = 1

    This dll belongs to another benchmark software which displays FPS just like FRAPS.

    Now the problem was that FRAPS also hooks its own DLL to display FPS in a game process , and i assume the conflict of both these DLL files was the reason why FRAPS couldnt work.

    Solution:
    Set AppInit_DLLs = [empty] or simply ""
    LoadAppInit_DLLs = 0 to disable any global hooking

    Restart the system. :)
    _________________________________________
     
    raffriff likes this.
  5. ETAdmin

    ETAdmin Administrator Staff Member

    very nice, thanks for posting this
     
  6. Sorry, noob here, dunno what you mean in the solution would you mind telling me in noob language
     
  7. Thalmor Wizard

    Thalmor Wizard is a Skyrim addict Staff Member Site Contributor

    This is a three year old thread for a very old Fraps version, you don't need to perform the solution above as it was already fixed anyway.
     
  8. sorry but fraps still wont work for me it wont target a window
     
  9. raffriff

    raffriff Moderator Staff Member Site Contributor

    Please start a new thread. Explain what the problem is exactly, what program are you trying to record, and also, get Frafs Hardware Check and post the report :)
     
    Thalmor Wizard likes this.
Thread Status:
Not open for further replies.

Share This Page