FRAPS Glitch When Recording Minecraft (I'm Clueless)

So I have an HP Laptop. I have had it for 4 months, and it has been nothing but good to me. I record Minecraft using FRAPS. During the past week my PC has been going very slow. My first inclination was to update the graphics driver. I did this, but later learned the problem was something else and I fixed it. However, I noticed that after updating the driver, my recorded Minecraft files all turn out like this:



I have a fair amount of experience with recording Minecraft, but this is beyond Me. I have Googled it, and it's something nobody seems to have experienced yet. I have tried other recording software and the only one that makes my videos like this is FRAPS. I would use the other software, but FRAPS performs best on my PC. I have tried reinstalling FRAPS 3 times.

It doesn't look like this while recording, just on the recorded file.

Please help. ;-;
 

Thalmor Wizard

Moderator
Staff member
Site Contributor
Unfortunately, I can't be of much assistance, since I've moved on from using Fraps. I use things like Shadowplay (well used to, before nVidia basically deleted it >_>) and OBS Studio for all my PC recording needs.
 
I think it has something to do with the video card an not really the recording. Can you maybe upload a video and share it with us. Like I said I think it is something with your drivers. So try re-installing.
 
I think it has something to do with the video card an not really the recording. Can you maybe upload a video and share it with us. Like I said I think it is something with your drivers. So try re-installing.
Oh it definitely is the driver. Unfortunately because this was the latest windows update, there hasn't been enough time for other people to experience the issue. I have tried rolling back the graphics driver before, and because it was a Windows update I couldn't. I have reinstalled 4 different versions of FRAPS.
 
it's sad, I'm getting the same error.

I've updated my drivers.
I have no graphics card, so no need to check that ;¬)
It doesn't happen in other games.
I've tested.
200% getting on my nerves.
PLZ HELP
 

Thalmor Wizard

Moderator
Staff member
Site Contributor
See my previous posts in this thread:
There was an issue like this reported on the forum before, but I don't recall what thread it was or what the solution was. You can have a look through some of these threads relating to "Minecraft" on the forum using this link: https://encodingtalk.com/search/search/?keywords=minecraft
Unfortunately, I can't be of much assistance, since I've moved on from using Fraps. I use things like Shadowplay (well used to, before nVidia basically deleted it >_>) and OBS Studio for all my PC recording needs.
 

billman

Well-Known Member
Site Contributor
Hi CompBox

Just at a guess your laptop has a recent nVidia Laptop?
GTX 900 and 1000 series do a memory compression trick to increase the "effective" bandwidth for the GPU's ram.
https://en.wikipedia.org/wiki/GeForce_900_series
Second generation Maxwell introduced several new technologies:
- Dynamic Super Resolution,[14]
- Third Generation Delta Color Compression,[15]
This looks very muck like Fraps is capturing the "compressed" version of the image.
Problem is this feature is baked into the hardware of the GPU.
My guess would be the recent driver update has enable this feature to work with Minecraft.

I am assuming alot here but 2 soluition
1. Revert your GPU driver to a very early version (HP website should have it)
2. Move to Shadowplay or MSI afterburner as these have been developed for modern GPU's

Fraps is archaic and the last update was to support SSE2.
There may be a way to force the Delta Color Compression off but I am yet to look in to that.
Confirm your specs for me and I should be able to provide some things to try.
 
Top