Fraps suddenly doesn't record anymore.

Discussion in 'FRAPS Help Requests' started by MrPithlit, Sep 19, 2011.

Thread Status:
Not open for further replies.
  1. Hello,

    For the past 3 months I have been succesfully recording my gameplay using fraps. The only problem I had was that my laptop didn't support any form in in-game sound recording. In order to try and solve this problem I've bought a USB-soundcard (a Sweex 7.1 External USB Sound Card to be precise). As soon as I had installed all the drivers for the sound card, Fraps couldn't record anything anymore. When I'm in a game and press F9, the game freezes for a few seconds and then nothing happens. The game starts working again, but Fraps isn't recording. I have noticed that Fraps does makes a movie file in the assigned folder while the game freezes, but it is removed as soon as the freeze stops.

    I'm using the newest version of Fraps on a Toshiba Satellite Pro A300, with 4Gb of RAM. My OS is Windows XP with sp3. I mainly try to record Minecraft, but other games aren't working either.
    I have tried the following solutions:
    - Reinstalling Fraps
    - Reinstalling the game
    - Removing the drivers for the usb soundcard
    - Update my sound and video drivers (for both the onboard soundcard and the usb sound card)
    - Using Fraps with other games

    The thing that's really strange is that after I'd removed the drivers and software for the usb sound-card (which I believed to have caused the problems in the first place), Fraps still wouldn't record.

    I read in a post on this forums that a possible solution would be to check the box 'Record External Input', but that option doesn't seem to exist in XP.

    Also I would like to point out that all other features of Fraps do work. I can see the FPS-counter, make screenshots and make a benchmark. Only video-recording stopped working.

    I hope I have given enough information to come to a solution, if not please let me know what else you need. I hope someone can help me out.

    Pithlit
     
  2. raffriff

    raffriff Moderator Staff Member Site Contributor

    Wow tough one.

    Do you still see your old sound module in the Sound Recording / Default Device list?
    xp-sound-audio.jpg

    ...how about here?
    xp-Fraps-movies.jpg
     
  3. Thanks for the reply! Hmm, if that's true than I hope you like a challenge..

    Yes, while the usb soundcard was installed, I could still see and select my standard onboard soundcard in the Windows sound settings (which didn't solve the problem), but I can't change the device in Fraps. Fraps used the usb card as standard device, and switching between 'best option' and 'windows default' (even after changing that back to onboard card) didn't make a difference..
     
  4. raffriff

    raffriff Moderator Staff Member Site Contributor

    But now the USB sound card is completely gone from both of those locations, right?

    Well I got nuthin' :( except maybe...
    System Restore? Hardly ever works, but sometimes it does...
    Search the registry for any sign of the old card & remove...
    Try removing Fraps, reinstalling sound card, reinstalling Fraps...?
     
  5. OK, good news! I've once again reinstalled both my old soundcard drivers and my usb soundcard and tried to record Minecraft. That didn't work, same problem as before. However, after that I tried Fable the lost chapters and that did work (even with the usb soundcard).
    Any ideas why it works with Fable but not with Minecraft?
    In the meantime I'll check some other games to see if I can find a pattern..
     
  6. I think I've found a pattern. Most games seem to work without problems (Fable, Need for Speed, Heroes of Might and Magic 3), but any game written in Java causes problems (Minecraft, Tribal Trouble, Project Zomboid). I've updated to the newest version of Java to see if that helps, but it didn't. Any ideas?
     
  7. Was there any resolution to this problem?

    This is the exact same issue I've started to have (hit record, locks for a second, then starts up but doesn't record).
     
  8. No, I haven't found a solution yet. I still can't record my java games. Suggestions are still more than welcome..
    Do you also have the problem with Java games only, or other games as well?
     
  9. It's actually all games for me (including just recording my desktop).
     
  10. I am having the same problem. I previously recorded minecraft videos, and it worked fine.
    But suddenly I cant. I start recording and the FPS goes red (normal) but then minecraft just freezes and I have to end the process.

    My PC specs
    Windows7 64bit
    4GB ram
    Intel core i5-2410M
    Intel HD graphics 3000

    Please help!
     
  11. raffriff

    raffriff Moderator Staff Member Site Contributor

  12. ciarlo2006

    ciarlo2006 Site Contributor Well-Known Member

    Did that solve it for either of you? I remember having the same problems a few years back but I can't remember how I solved it. Back then I had a tendancy to just re-install windows whenever something broke.

    To me it sounds like it may be the hard-drive, but then if it's only for Java for Andit, then it makes it a bit more confusing.
     
  13. Ill try CystalDiskMark and see what it says, if its bad then I might re-install windows but Ill test it with games that dont run java.
    Thanks.
     
  14. So I have done the test and this is what I got:
    Code:
    -----------------------------------------------------------------------
    CrystalDiskMark 3.0.1 x64 (C) 2007-2010 hiyohiyo
                              Crystal Dew World : http://crystalmark.info/
    -----------------------------------------------------------------------
    * MB/s = 1,000,000 byte/s [SATA/300 = 300,000,000 byte/s]
     
              Sequential Read :    85.703 MB/s
              Sequential Write :    93.929 MB/s
            Random Read 512KB :    0.000 MB/s
            Random Write 512KB :    0.000 MB/s
        Random Read 4KB (QD=1) :    0.000 MB/s [    0.0 IOPS]
      Random Write 4KB (QD=1) :    0.000 MB/s [    0.0 IOPS]
      Random Read 4KB (QD=32) :    0.000 MB/s [    0.0 IOPS]
      Random Write 4KB (QD=32) :    0.000 MB/s [    0.0 IOPS]
     
      Test : 4000 MB [C: 68.9% (155.1/225.3 GB)] (x3)
      Date : 2012/06/07 12:38:55
        OS : Windows 7 Home Premium Edition [6.1 Build 7600] (x64)
      
    Please tell me if this is good. Thanks.
     
  15. raffriff

    raffriff Moderator Staff Member Site Contributor

    That's great - your HDD is in good shape. Now to try recording some non-Java games...

    Oh, and try:
    Follow the link to that thread - there are some other ideas that need to be tried

    What FPS are you getting in Minecraft without recording?
     
  16. Ok so opening fraps before minecraft helps a bit (It shows the fps)

    And my normal fps in minecraft is 60.

    So I hit Controll+R (My recording hot key) and the FPS turns red, as normal, but then it freezes and I need to go into task manager to end the Java process. After this all sorts of other things stop working like the volume controll windows media player and flash player.

    To continue working my computer as normal I have to restart. So Ill do that now also could you give me an example of other types of games that FRAPS records?

    Thanks.
     
  17. ciarlo2006

    ciarlo2006 Site Contributor Well-Known Member

    Fraps should record any OpenGL and DirectX application, which is pretty much any game. You could try something free like Team Fortress 2 or League of Legends.

    I'm not sure what type of hooking has to be done with a Java game, but I suspect it's related. I presume it may be OpenGL, and if so, I don't see why it would have problems. So confusing.
     
  18. Thalmor Wizard

    Thalmor Wizard Moderator Staff Member Site Contributor

    Try changing the performance setting to Power Saver and set Fraps to record at only 30fps. If that doesn't work, then you might want to report this to beepa on the fraps.com site.
     
  19. raffriff

    raffriff Moderator Staff Member Site Contributor

  20. Ok so I did that and it worked. But the seconed time I tried to record, it stoped working again!
     
Thread Status:
Not open for further replies.

Share This Page