No sound when recording with FRAPS [SOLVED]

Discussion in 'FRAPS Help Requests' started by matraklirahn, Jul 29, 2010.

Thread Status:
Not open for further replies.
  1. No sound when recording with FRAPS. -=FIXED=-

    Right, i have looked through most of the posts regarding non recording of sound when using FRAPS and i havent had any luck with that. So throw this out to you (again) oh board of guru's!

    Trying to record ANY gametype with fraps. Have tested it with Modern Warfare 2 Multiplayer and Left 4 Dead 2 and i stil get the same problem which is:

    No game sound is recorded whatsoever!

    Video is fine, but i dont even get a PEEP of sound.

    My current setup goes a little like this:

    Windows 7 64bit
    Asus Xonar D2x soundcard
    Recording onto a DIFFERENT drive than where my OS is installed
    FPS is set to around 50 or so
    Recording at HALF SIZE
    Record Win7 sound is CHECKED
    Record from external sound is UNCHECKED (or i just hear my mic going and thats a bit pointless. No one wants to hear me cursing madly at tripping over a claymore)
    Do not sync audio and video is UNCHECKED (so i assume its on?)
    Force lossless RGB is UNCHECKED

    I mange to record a bunch of 3.9 gig files (which i believe is the standard size for FRAPS to cap at) and still nothing.

    Any reason why there would be no sound being recorded with this, as as far as i can tell. Everything should work fine.

    Any help would be greatly apreciated!
     
  2. ciarlo2006

    ciarlo2006 Site Contributor Well-Known Member

    Record from external input and change your windows recording device to What You Hear/Stereo.
     
  3. @ciarlo2006

    It doesnt give me that option. There is no drop down menu or choice of recording devices. If i record from an external device it defaults to my mic, and thereis no way i can change that.

    FYI Using Fraps 3.2.3
     
  4. ciarlo2006

    ciarlo2006 Site Contributor Well-Known Member

    Ok let me explain.

    In fraps, tick record from external input.
    In fraps, untick Record Win7 sound.

    In windows, down the bottom of your desktop on the toolbar, rick click your speaker and click recording devices.

    In recording devices, find either What You Hear or Stereo, depending on what your sound card uses, and set it to default.

    If it is not in that list, try right clicking in the list and turn on show disabled devices.

    If you find it but still get no sound, you might have to play around with the What you hear settings in recording devices as its normally not setup right by default.
     
    raffriff likes this.
  5. Thanks for the update and detailed how to.

    Unfortunately in FRAPS, it does NOT let me choose from a list of different recording devices, including the external inouts. Even after i reset FRAPS or restart the program. I see the Stereo mix in my recording devices and also see it as ready (where it used to be unavailable)

    I will give it a shot and post an update here when i have done so!
     
  6. @ciarlo2006

    Well after following our instructions and fiddling around a bit more i finally got it to work! I was rather giddy when i heard those sweet gunshots coming from my speakers!!

    For those who want to know and just to reiterate what @Ciarlo2006 said

    First off

    Windows sound, recording tab (for windows 7/vista) then make sure you have an option called 'Stereo Mix' or in some cards its callled 'What you hear'

    Make sure the Stereo Mix or What You Hear is selected and has a tick next to it. Under windows 7 there is a drop down box at the bottom of the device list that can allow you to set it as either the default device or default communication device.

    Since i still USE my mic, i don't want to set it as my default communication device :p

    IF YOU DO NOT SEE THESE OPTIONS:

    Right click anywhere near the listed sound options and choose to 'show disabled devices'

    Then see if you have it in there, it SHOULD pop up. Enable it and repeat the steps above.

    THEN IN FRAPS:

    To quote the wonderful, simple instructions that Ciarlo2006 gave me:

    In fraps, tick record from external input.
    In fraps, untick Record Win7 sound.

    It is IMPORTANT that you untick 'record Win7 sound'

    Because for some UNBEKNOWN REASON ti will not record the sound. Kinda retarded but maybe its looking for the default onboard sound? I dunno.

    After that, give it a few test records with a game. I had a few trial and error runs and it finally worked!

    Many thanks for the help!
     
  7. ciarlo2006

    ciarlo2006 Site Contributor Well-Known Member

    Forgot to say you needed to restart Fraps.
     
  8. Here's is what helped with me. With Fraps, Make sure latest one and My Realtek audio drivers needed to e updated : )
     
  9. I followed all the instructions EXACTLY, and i still get no game sound when recording. The only sound i get is a quick blip, beep, or screech in the begining when i start play the video i just recorded. Its really weird because Fraps was just working perfectly a few hours ago and all of a sudden its not. At first i thought it was because i had installed Audacity but now that i uninstalled it i know there is something wrong with Fraps.

    Any suggestions on what i can do to resolve this issue?
     
  10. ETAdmin

    ETAdmin Administrator

    Try reinstalling fraps now that you have removed audacity, though I've never heard of it messing up the ability to record audio.
     
  11. Thalmor Wizard

    Thalmor Wizard is a Skyrim addict Staff Member Site Contributor

    Neither have I, but there's always a first for everything ;)
     
  12. Yeah i tried that. Didint work. I still get an odd screeching noise in the begining when the video starts to play but again no sound after that. Iv tried everything i could think of. And its really weird because i even did a complete system reset (like took it back to day 1), didint even touch Audacity and im still having issues with Fraps. So the problem is not with Audacity, its with fraps and it seems like its un-fixable unless theres something im missing that you guys know about
     
  13. Thalmor Wizard

    Thalmor Wizard is a Skyrim addict Staff Member Site Contributor

    What is the audio card that your computer is using ? Check for updates and if you are up-to-date, try rolling back the drivers to an older version. This isn't a problem with Fraps or we would all get this. I love how people are quick to blame the software before their own computers >_>
     
  14. I use a Realtek High Definition Audio
    The computer refers it as "Stereo Mix"

    I did try rolling the drivers back, didint work, updated them. Didint work.
     
  15. Thalmor Wizard

    Thalmor Wizard is a Skyrim addict Staff Member Site Contributor

    Please record a sample video and upload it to YouTube (you can use Unlisted if you don't want others to see the video)
     
  16. So..in the process of doing that i discovered that when i preview the video with Youtube Movie Maker, i can hear the sound perfectly. So maybe its a problem with Windows Media Player because thats what i generally preview the clips i make in
     
  17. Thalmor Wizard

    Thalmor Wizard is a Skyrim addict Staff Member Site Contributor

    It's recommended to encode videos in a movie editor and not play back raw footage in WMP. And I've never heard of YouTube Movie Maker, I think you may mean Windows (Live) Movie Maker.
     
Thread Status:
Not open for further replies.

Share This Page